re = /(?<![a-z:])name:|:name(?![a-z:])/m
str = 'name: | :name | name:`asdf`
But should not match any of these:
:name:
eman:
nnamee:
:nameasdfj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end