package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.com\\([^\\]+)\\.*`)
var str = `SERVERNAME2018-03-08 18:40:28 File: "x:\_default\app.address.com\MedSoftware\.data\BackEnd.com\Technical.Dictionaries.Service-180308182311\Web.config", Name: "dictionaries_data_product", CS: "###connectionStrings.dictionariesdataproduct.connectionString" info: Format of the initialization string does not conform to specification starting at index 0. 6069
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}