// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.com\\([^\\]+)\\.*").unwrap();
let string = "SERVERNAME2018-03-08 18:40:28 File: \"x:\\_default\\app.address.com\\MedSoftware\\.data\\BackEnd.com\\Technical.Dictionaries.Service-180308182311\\Web.config\", Name: \"dictionaries_data_product\", CS: \"###connectionStrings.dictionariesdataproduct.connectionString\" info: Format of the initialization string does not conform to specification starting at index 0. 6069
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}