const regex = /\.com\\([^\\]+)\\.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.com\\\\([^\\\\]+)\\\\.*', 'g')
const str = `SERVERNAME2018-03-08 18:40:28 File: "x:\\_default\\app.address.com\\MedSoftware\\.data\\BackEnd.com\\Technical.Dictionaries.Service-180308182311\\Web.config", Name: "dictionaries_data_product", CS: "###connectionStrings.dictionariesdataproduct.connectionString" info: Format of the initialization string does not conform to specification starting at index 0. 6069
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}