import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.com\\\\([^\\\\]+)\\\\.*";
final String string = "SERVERNAME2018-03-08 18:40:28 File: \"x:\\_default\\app.address.com\\MedSoftware\\.data\\BackEnd.com\\Technical.Dictionaries.Service-180308182311\\Web.config\", Name: \"dictionaries_data_product\", CS: \"###connectionStrings.dictionariesdataproduct.connectionString\" info: Format of the initialization string does not conform to specification starting at index 0. 6069\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}