import Foundation
let pattern = #"\.com\\([^\\]+)\\.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ####"""
SERVERNAME2018-03-08 18:40:28 File: "x:\_default\app.address.com\MedSoftware\.data\BackEnd.com\Technical.Dictionaries.Service-180308182311\Web.config", Name: "dictionaries_data_product", CS: "###connectionStrings.dictionariesdataproduct.connectionString" info: Format of the initialization string does not conform to specification starting at index 0. 6069
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)