use strict;
my $str = 'SERVERNAME2018-03-08 18:40:28 File: "x:\\_default\\app.address.com\\MedSoftware\\.data\\BackEnd.com\\Technical.Dictionaries.Service-180308182311\\Web.config", Name: "dictionaries_data_product", CS: "###connectionStrings.dictionariesdataproduct.connectionString" info: Format of the initialization string does not conform to specification starting at index 0. 6069
';
my $regex = qr/\.com\\([^\\]+)\\.*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}