using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[(\w+)]]((?>[^[]+|\[[^[])*)\[\[/\1]]";
string input = @"Example 1
[[section_abc]]
<div>
several lines of html ...
</div>
[[/section_abc]]
Example 2
[[section_opq]]
<div>
several lines of html ...
</div>
[[/section_opq]]
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}