const regex = new RegExp('\\[\\[(\\w+)]]((?>[^[]+|\\[[^[])*)\\[\\[/\\1]]', 'gs')
const str = `Example 1
[[section_abc]]
<div>
several lines of html ...
</div>
[[/section_abc]]
Example 2
[[section_opq]]
<div>
several lines of html ...
</div>
[[/section_opq]]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}