$re = '`\[\[(\w+)]]((?>[^[]+|\[[^[])*)\[\[/\1]]`s';
$str = 'Example 1
[[section_abc]]
<div>
several lines of html ...
</div>
[[/section_abc]]
Example 2
[[section_opq]]
<div>
several lines of html ...
</div>
[[/section_opq]]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);