re = /\[\[(\w+)]]((?>[^[]+|\[[^[])*)\[\[\/\1]]/
str = 'Example 1
[[section_abc]]
<div>
several lines of html ...
</div>
[[/section_abc]]
Example 2
[[section_opq]]
<div>
several lines of html ...
</div>
[[/section_opq]]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end