import re
regex = re.compile(r"\[\[(\w+)]]((?>[^[]+|\[[^[])*)\[\[/\1]]", flags=re.DOTALL)
test_str = ("Example 1\n\n"
"[[section_abc]]\n"
"<div>\n"
"several lines of html ...\n"
"</div>\n"
"[[/section_abc]]\n\n"
"Example 2\n\n"
"[[section_opq]]\n"
"<div>\n"
"several lines of html ...\n"
"</div>\n"
"[[/section_opq]]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")