import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[(\\w+)]]((?>[^[]+|\\[[^[])*)\\[\\[/\\1]]";
final String string = "Example 1\n\n"
+ "[[section_abc]]\n"
+ "<div>\n"
+ "several lines of html ...\n"
+ "</div>\n"
+ "[[/section_abc]]\n\n"
+ "Example 2\n\n"
+ "[[section_opq]]\n"
+ "<div>\n"
+ "several lines of html ...\n"
+ "</div>\n"
+ "[[/section_opq]]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}