using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)[a-zA-Z]*[:/]*[\w-]+\.+[\w:./%&=?-]+(?!\S)";
string input = @"test@test.com
test example@example.com
example@example.co.uk
test
www.test.com
example.com
www.example.com
test sub.example.com test
http://example.com
test http://www.example.com test
http://sub.example.com
https://example.com
https://www.example.com
https://sub.example.com
git://github.com/user/project-name.git
irc://test.test.com:8080/test test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}