re = /(?<!\S)[a-zA-Z]*[:\/]*[\w-]+\.+[\w:.\/%&=?-]+(?!\S)/m
str = 'test@test.com
test example@example.com
example@example.co.uk
test
www.test.com
example.com
www.example.com
test sub.example.com test
http://example.com
test http://www.example.com test
http://sub.example.com
https://example.com
https://www.example.com
https://sub.example.com
git://github.com/user/project-name.git
irc://test.test.com:8080/test test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end