use strict;
my $str = 'test@test.com
test example@example.com
example@example.co.uk
test
www.test.com
example.com
www.example.com
test sub.example.com test
http://example.com
test http://www.example.com test
http://sub.example.com
https://example.com
https://www.example.com
https://sub.example.com
git://github.com/user/project-name.git
irc://test.test.com:8080/test test';
my $regex = qr~(?<!\S)[a-zA-Z]*[:/]*[\w-]+\.+[\w:./%&=?-]+(?!\S)~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}