import re
regex = re.compile(r"(?<!\S)[a-zA-Z]*[:/]*[\w-]+\.+[\w:./%&=?-]+(?!\S)", flags=re.MULTILINE)
test_str = ("test@test.com\n"
"test example@example.com\n"
"example@example.co.uk\n"
"test\n"
"www.test.com\n\n"
"example.com\n"
"www.example.com\n"
"test sub.example.com test\n"
"http://example.com\n"
"test http://www.example.com test\n"
"http://sub.example.com\n"
"https://example.com\n"
"https://www.example.com\n"
"https://sub.example.com\n"
"git://github.com/user/project-name.git\n"
"irc://test.test.com:8080/test test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")