import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)[a-zA-Z]*[:/]*[\\w-]+\\.+[\\w:./%&=?-]+(?!\\S)";
final String string = "test@test.com\n"
+ "test example@example.com\n"
+ "example@example.co.uk\n"
+ "test\n"
+ "www.test.com\n\n"
+ "example.com\n"
+ "www.example.com\n"
+ "test sub.example.com test\n"
+ "http://example.com\n"
+ "test http://www.example.com test\n"
+ "http://sub.example.com\n"
+ "https://example.com\n"
+ "https://www.example.com\n"
+ "https://sub.example.com\n"
+ "git://github.com/user/project-name.git\n"
+ "irc://test.test.com:8080/test test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}