#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(For|From).*$"
Local $sString = "The Consequences of Hostilities Between the States" & @CRLF & _
"" & @CRLF & _
"From the New York Packet." & @CRLF & _
"" & @CRLF & _
"Tuesday, November 20, 1787." & @CRLF & _
"" & @CRLF & _
"HAMILTON" & @CRLF & _
"" & @CRLF & _
"To the People of the State of New York:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")