package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(For|From).*$`)
var str = `The Consequences of Hostilities Between the States
From the New York Packet.
Tuesday, November 20, 1787.
HAMILTON
To the People of the State of New York:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}