import re
regex = re.compile(r"^(For|From).*$", flags=re.MULTILINE)
test_str = ("The Consequences of Hostilities Between the States\n\n"
"From the New York Packet.\n\n"
"Tuesday, November 20, 1787.\n\n"
"HAMILTON\n\n"
"To the People of the State of New York:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")