$re = '/\*([\w ^?.]*?)\*/';
$str = 'Chicken teriy*ai*ki r*ai*men noodles, spaghetti a la moneg*ai*sque.
^*Have I seen^ you before?*';
$subst = "<em>\1<\em>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;