import Foundation
let pattern = #"\*([\w ^?.]*?)\*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Chicken teriy*ai*ki r*ai*men noodles, spaghetti a la moneg*ai*sque.
^*Have I seen^ you before?*
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<em>\1<\em>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)