#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)##\s\[v0.0.1].+?(?=---)"
Local $sString = "# Changelog" & @CRLF & _
"" & @CRLF & _
"All notable changes to this project will be documented in this file." & @CRLF & _
"Please not that all entrys must end with `---` to allow for the auto release body to use the Changelog" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"## [v0.0.1]" & @CRLF & _
"" & @CRLF & _
"### Added" & @CRLF & _
"- Initial Commit/Release" & @CRLF & _
"---"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")