re = /(?s)##\s\[v0.0.1].+?(?=---)/m
str = '# Changelog
All notable changes to this project will be documented in this file.
Please not that all entrys must end with `---` to allow for the auto release body to use the Changelog
## [v0.0.1]
### Added
- Initial Commit/Release
---'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end