const regex = /(?s)##\s\[v0.0.1].+?(?=---)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)##\\s\\[v0.0.1].+?(?=---)', 'gm')
const str = `# Changelog
All notable changes to this project will be documented in this file.
Please not that all entrys must end with \`---\` to allow for the auto release body to use the Changelog
## [v0.0.1]
### Added
- Initial Commit/Release
---`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}