use strict;
my $str = '# Changelog
All notable changes to this project will be documented in this file.
Please not that all entrys must end with `---` to allow for the auto release body to use the Changelog
## [v0.0.1]
### Added
- Initial Commit/Release
---';
my $regex = qr/(?s)##\s\[v0.0.1].+?(?=---)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}