import Foundation
let pattern = ###"(?s)##\s\[v0.0.1].+?(?=---)"###
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####"""
# Changelog
All notable changes to this project will be documented in this file.
Please not that all entrys must end with `---` to allow for the auto release body to use the Changelog
## [v0.0.1]
### Added
- Initial Commit/Release
---
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)