$re = '/(?s)##\s\[v0.0.1].+?(?=---)/m';
$str = '# Changelog
All notable changes to this project will be documented in this file.
Please not that all entrys must end with `---` to allow for the auto release body to use the Changelog
## [v0.0.1]
### Added
- Initial Commit/Release
---';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);