#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)p(\d+)(?:&p(\d+))?\.([^.]+)\."
Local $sString = "MyTestString1-id1p01&p02.Part1And2.txt" & @CRLF & _
"', // 1-2. Part1And2.txt" & @CRLF & _
"MyTestString2-id1p03.Part3.txt" & @CRLF & _
"', // 3. Part3.txt" & @CRLF & _
"MyTestString3-id1p04.Part4.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")