$re = '/p(\d+)(?:&p(\d+))?\.([^.]+)\./m';
$str = 'MyTestString1-id1p01&p02.Part1And2.txt
\', // 1-2. Part1And2.txt
MyTestString2-id1p03.Part3.txt
\', // 3. Part3.txt
MyTestString3-id1p04.Part4.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);