import Foundation
let pattern = #"p(\d+)(?:&p(\d+))?\.([^.]+)\."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MyTestString1-id1p01&p02.Part1And2.txt
', // 1-2. Part1And2.txt
MyTestString2-id1p03.Part3.txt
', // 3. Part3.txt
MyTestString3-id1p04.Part4.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)