use strict;
my $str = 'MyTestString1-id1p01&p02.Part1And2.txt
\', // 1-2. Part1And2.txt
MyTestString2-id1p03.Part3.txt
\', // 3. Part3.txt
MyTestString3-id1p04.Part4.txt';
my $regex = qr/p(\d+)(?:&p(\d+))?\.([^.]+)\./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}