import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "p(\\d+)(?:&p(\\d+))?\\.([^.]+)\\.";
final String string = "MyTestString1-id1p01&p02.Part1And2.txt\n"
+ "', // 1-2. Part1And2.txt\n"
+ "MyTestString2-id1p03.Part3.txt\n"
+ "', // 3. Part3.txt\n"
+ "MyTestString3-id1p04.Part4.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}