package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)p(\d+)(?:&p(\d+))?\.([^.]+)\.`)
var str = `MyTestString1-id1p01&p02.Part1And2.txt
', // 1-2. Part1And2.txt
MyTestString2-id1p03.Part3.txt
', // 3. Part3.txt
MyTestString3-id1p04.Part4.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}