#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((\d+)(\.\d+)?([a-zA-Z]*)\s(\w*))+( X )?"
Local $sString = "Ice block - 20cm Diameter X 40cm Height (Picture) Also Available In Ice block - 20cm Diameter X 63cm Height. Ice block - 20cm Diameter X 80cm Height ." & @CRLF & _
"" & @CRLF & _
"Glass Vase - 58.5cm Diameter X 60.5cm Width X 80cm Height. Vase Height - 46.5cm New Glass Vase decorative flower detail" & @CRLF & _
"" & @CRLF & _
"(\d+)(\.\d+)([a-zA-Z]*)\s(\w*)( X )(\d+)(\.\d+)([a-zA-Z]*)\s(\w*)( X )(\d+)([a-zA-Z]*)\s(\w*) - works for 3" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")