using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d+)(\.\d+)?([a-zA-Z]*)\s(\w*))+( X )?";
string input = @"Ice block - 20cm Diameter X 40cm Height (Picture) Also Available In Ice block - 20cm Diameter X 63cm Height. Ice block - 20cm Diameter X 80cm Height .
Glass Vase - 58.5cm Diameter X 60.5cm Width X 80cm Height. Vase Height - 46.5cm New Glass Vase decorative flower detail
(\d+)(\.\d+)([a-zA-Z]*)\s(\w*)( X )(\d+)(\.\d+)([a-zA-Z]*)\s(\w*)( X )(\d+)([a-zA-Z]*)\s(\w*) - works for 3
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}