const regex = /((\d+)(\.\d+)?([a-zA-Z]*)\s(\w*))+( X )?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d+)(\\.\\d+)?([a-zA-Z]*)\\s(\\w*))+( X )?', 'g')
const str = `Ice block - 20cm Diameter X 40cm Height (Picture) Also Available In Ice block - 20cm Diameter X 63cm Height. Ice block - 20cm Diameter X 80cm Height .
Glass Vase - 58.5cm Diameter X 60.5cm Width X 80cm Height. Vase Height - 46.5cm New Glass Vase decorative flower detail
(\\d+)(\\.\\d+)([a-zA-Z]*)\\s(\\w*)( X )(\\d+)(\\.\\d+)([a-zA-Z]*)\\s(\\w*)( X )(\\d+)([a-zA-Z]*)\\s(\\w*) - works for 3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}