import Foundation
let pattern = #"((\d+)(\.\d+)?([a-zA-Z]*)\s(\w*))+( X )?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Ice block - 20cm Diameter X 40cm Height (Picture) Also Available In Ice block - 20cm Diameter X 63cm Height. Ice block - 20cm Diameter X 80cm Height .
Glass Vase - 58.5cm Diameter X 60.5cm Width X 80cm Height. Vase Height - 46.5cm New Glass Vase decorative flower detail
(\d+)(\.\d+)([a-zA-Z]*)\s(\w*)( X )(\d+)(\.\d+)([a-zA-Z]*)\s(\w*)( X )(\d+)([a-zA-Z]*)\s(\w*) - works for 3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)