re = /((\d+)(\.\d+)?([a-zA-Z]*)\s(\w*))+( X )?/
str = 'Ice block - 20cm Diameter X 40cm Height (Picture) Also Available In Ice block - 20cm Diameter X 63cm Height. Ice block - 20cm Diameter X 80cm Height .
Glass Vase - 58.5cm Diameter X 60.5cm Width X 80cm Height. Vase Height - 46.5cm New Glass Vase decorative flower detail
(\\d+)(\\.\\d+)([a-zA-Z]*)\\s(\\w*)( X )(\\d+)(\\.\\d+)([a-zA-Z]*)\\s(\\w*)( X )(\\d+)([a-zA-Z]*)\\s(\\w*) - works for 3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end