# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=, |^)\b([()\w\s]+),\s(.*?)((?: and)?(?=\1))|\w=\(.*?\)/$2/gm;t' <<< "height(female), weight, BMI, and BMI.
height(female), weight, whatever it is, and whatever it is.
height(female), weight, age, height(female), and BMI.
weight, weight."