$re = '/(?<=, |^)\b([()\w\s]+),\s(.*?)((?: and)?(?=\1))|\w=\(.*?\)/m';
$str = 'height(female), weight, BMI, and BMI.
height(female), weight, whatever it is, and whatever it is.
height(female), weight, age, height(female), and BMI.
weight, weight.';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;