const regex = /(?<=, |^)\b([()\w\s]+),\s(.*?)((?: and)?(?=\1))|\w=\(.*?\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=, |^)\\b([()\\w\\s]+),\\s(.*?)((?: and)?(?=\\1))|\\w=\\(.*?\\)', 'gm')
const str = `height(female), weight, BMI, and BMI.
height(female), weight, whatever it is, and whatever it is.
height(female), weight, age, height(female), and BMI.
weight, weight.`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);