import Foundation
let pattern = #"(?<=, |^)\b([()\w\s]+),\s(.*?)((?: and)?(?=\1))|\w=\(.*?\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
height(female), weight, BMI, and BMI.
height(female), weight, whatever it is, and whatever it is.
height(female), weight, age, height(female), and BMI.
weight, weight.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)