#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=, |^)\b([()\w\s]+),\s(.*?)((?: and)?(?=\1))|\w=\(.*?\)"
Local $sString = "height(female), weight, BMI, and BMI." & @CRLF & _
"height(female), weight, whatever it is, and whatever it is." & @CRLF & _
"height(female), weight, age, height(female), and BMI." & @CRLF & _
"weight, weight."
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)