using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?>(?<!\\"""").)+$";
string input = @"""""asdasd"""" // group (полное соотвествие)
""""a""sda""sd"""" // group (полное соотвествие, нет трёх кавычек)
""""a""s""dasd"""" // group (полное соотвествие, нет трёх кавычек)
""""asdas""d"""" // group (полное соотвествие, нет трёх кавычек)
""""a""sd""a\""""sd"""" // group (полное соотвествие, группа заэкранированна)
""""asd\""""a""sd"""" // group (полное соотвествие, группа заэкранированна)
""""asd""""sdfsdf"""" // group + sdfsdf (соотвествие только первой части)
""""a""sd""""sdfsdf""""s""df"""" // group + sdfsdf + group (соответствие двум группам)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}