# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?>(?<!\\\"\"\").)+$"
test_str = ("\"\"\"asdasd\"\"\" // group (полное соотвествие)\n\n"
"\"\"\"a\"sda\"\"sd\"\"\" // group (полное соотвествие, нет трёх кавычек)\n\n"
"\"\"\"a\"s\"dasd\"\"\" // group (полное соотвествие, нет трёх кавычек)\n\n"
"\"\"\"asdas\"d\"\"\" // group (полное соотвествие, нет трёх кавычек)\n\n"
"\"\"\"a\"\"sd\"\"a\\\"\"\"sd\"\"\" // group (полное соотвествие, группа заэкранированна)\n\n"
"\"\"\"asd\\\"\"\"a\"\"sd\"\"\" // group (полное соотвествие, группа заэкранированна)\n\n"
"\"\"\"asd\"\"\"sdfsdf\"\"\" // group + sdfsdf (соотвествие только первой части)\n\n"
"\"\"\"a\"sd\"\"\"sdfsdf\"\"\"s\"\"df\"\"\" // group + sdfsdf + group (соответствие двум группам)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.