re = /^(?>(?<!\\""").)+$/m
str = '"""asdasd""" // group (полное соотвествие)
"""a"sda""sd""" // group (полное соотвествие, нет трёх кавычек)
"""a"s"dasd""" // group (полное соотвествие, нет трёх кавычек)
"""asdas"d""" // group (полное соотвествие, нет трёх кавычек)
"""a""sd""a\\"""sd""" // group (полное соотвествие, группа заэкранированна)
"""asd\\"""a""sd""" // group (полное соотвествие, группа заэкранированна)
"""asd"""sdfsdf""" // group + sdfsdf (соотвествие только первой части)
"""a"sd"""sdfsdf"""s""df""" // group + sdfsdf + group (соответствие двум группам)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end