const regex = /^(?>(?<!\\""").)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?>(?<!\\\\""").)+$', 'gm')
const str = `"""asdasd""" // group (полное соотвествие)
"""a"sda""sd""" // group (полное соотвествие, нет трёх кавычек)
"""a"s"dasd""" // group (полное соотвествие, нет трёх кавычек)
"""asdas"d""" // group (полное соотвествие, нет трёх кавычек)
"""a""sd""a\\"""sd""" // group (полное соотвествие, группа заэкранированна)
"""asd\\"""a""sd""" // group (полное соотвествие, группа заэкранированна)
"""asd"""sdfsdf""" // group + sdfsdf (соотвествие только первой части)
"""a"sd"""sdfsdf"""s""df""" // group + sdfsdf + group (соответствие двум группам)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}