import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>(?<!\\\\\"\"\").)+$";
final String string = "\"\"\"asdasd\"\"\" // group (полное соотвествие)\n\n"
+ "\"\"\"a\"sda\"\"sd\"\"\" // group (полное соотвествие, нет трёх кавычек)\n\n"
+ "\"\"\"a\"s\"dasd\"\"\" // group (полное соотвествие, нет трёх кавычек)\n\n"
+ "\"\"\"asdas\"d\"\"\" // group (полное соотвествие, нет трёх кавычек)\n\n"
+ "\"\"\"a\"\"sd\"\"a\\\"\"\"sd\"\"\" // group (полное соотвествие, группа заэкранированна)\n\n"
+ "\"\"\"asd\\\"\"\"a\"\"sd\"\"\" // group (полное соотвествие, группа заэкранированна)\n\n"
+ "\"\"\"asd\"\"\"sdfsdf\"\"\" // group + sdfsdf (соотвествие только первой части)\n\n"
+ "\"\"\"a\"sd\"\"\"sdfsdf\"\"\"s\"\"df\"\"\" // group + sdfsdf + group (соответствие двум группам)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}